美国Godaddy主机

海外主机侦探论坛

 找回密码
 注册

扫一扫,访问微社区

搜索
美国主机优惠信息汇总出售cPanel CloudLinux R1SoftGodaddy美国空间代购
国外主机资料导航支持支付宝付款的美国主机HostEase速度快中文客服!
查看: 1342|回复: 8

[提问] “MB 语言是默认的--No”应该在哪里改?

[复制链接]
发表于 2013-6-26 10:19:22 | 显示全部楼层 |阅读模式
HostEase美国主机商优惠码
我在网站上安装JOOMLA系统时,系统检测到2个问题,但在控制面板中没找到相应的设置,不知道应该怎么更改,烦请高手指点一下,谢谢。

MB 语言是默认的:         No
Register Globals:         Yes
 楼主| 发表于 2013-6-26 10:21:39 | 显示全部楼层
RAKSmart美国主机商2014新春优惠大促销
浏览器不知出什么问题图片上不了,只好把截屏上传为附件
22222.JPG
回复 支持 反对

使用道具 举报

发表于 2013-6-26 11:09:43 | 显示全部楼层
美国服务器
没试过,你可以在控制面板中找找,这个修改应该不会很难的
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-6-26 11:10:14 | 显示全部楼层
Godaddy美国主机2014年半价优惠大促销
找客服帮我解决了

Alex Nazarov: I've generated custom php.ini file for your domain and made requested changes. You may find it under parttime.ixtrial.com/cgi-bin folder. Please note that in order to keep php.ini settings work 3 files should be present under your domain folder:

Alex Nazarov: /cgi-bin/php.ini

Alex Nazarov: /cgi-bin/php5-custom-ini.cgi  - should have 755 permissions

Alex Nazarov: /.htaccess - should contain strings below:

Alex Nazarov: AddHandler phpini-cgi .php .htm

Alex Nazarov: Action phpini-cgi /cgi-bin/php5-custom-ini.cgi

Alex Nazarov: Also please follow this link
回复 支持 反对

使用道具 举报

发表于 2013-6-26 12:51:25 | 显示全部楼层
HostEase美国主机商优惠码
第一个:MB 语言是默认的:No
看你的图片显示的就是绿色的,应该就不需要改了
第二个:Register Globals你可以联系客服帮你修改
或者自定义php或者.htaccess的~
或者可以尝试ini_set('register_globals',0)来.
*自己在网站目录下新建一个.htaccess文件,加上
  1. php_flag register_globals off
复制代码
如果已有.htaccess文件,直接再最后另起一行添加即可;

*如果实在不行,那只有采用最后的办法直接去include/common.inc.php中将以下代码删除即可(不建议).
  1. ----
  2. //开启register_globals会有诸多不安全可能性,因此强制要求关闭register_globals
  3. if ( ini_get('register_globals') )
  4. {
  5.     exit('<a href="http://docs.dedecms.com/doku.php?id=register_globals">php.ini register_globals must is Off! </a>');
  6. }
  7. ----查看:php.ini session.auto_start must is 0 !
复制代码
以上仅供参考,因为我也没用过,解决方法也是来源于网络。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-6-26 14:58:40 | 显示全部楼层
HostEase美国主机商优惠码
谢谢楼上的答复,其实MD语言这项应该是YES的,截图时鼠标拉了一下反白,所以看不出是红色。

我找了客服,他们帮我解决了,下面是客服的回复:

I've generated custom php.ini file for your domain and made requested changes. You may find it under /cgi-bin folder. Please note that in order to keep php.ini settings work 3 files should be present under your domain folder:

/cgi-bin/php.ini
/cgi-bin/php5-custom-ini.cgi  - should have 755 permissions
/.htaccess - should contain strings below:
AddHandler phpini-cgi .php .htm
Action phpini-cgi /cgi-bin/php5-custom-ini.cgi

Also please follow this link /phpinfo.php here you can check all php settings for your domain.

客服改动后问题确实解决了,/cgi-bin文件夹我做了个备份。但在后续安装中写入数据库时出了错,于是我把所有文件都删了,重新安装,上传备份的/cgi-bin文件,可又出现之前同样的问题。而且我试着修改php.ini文件中的对应参数,却没有任何变化,真是奇怪了。
回复 支持 反对

使用道具 举报

发表于 2013-6-26 17:07:51 | 显示全部楼层
HostEase美国主机商优惠码
这学习了,我也有朋友遇到这问题。
回复 支持 反对

使用道具 举报

发表于 2013-6-26 17:49:53 | 显示全部楼层
HostEase美国主机商优惠码
eonfine 发表于 2013-6-26 02:58 PM
谢谢楼上的答复,其实MD语言这项应该是YES的,截图时鼠标拉了一下反白,所以看不出是红色。

我找了客服, ...

你的网站如果是刚刚做的话,大不了把文件和数据库全删了,重新来过~
回复 支持 反对

使用道具 举报

发表于 2013-8-8 10:47:44 | 显示全部楼层
美国服务器
学知识了
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

论坛言论由会员发布,不代表本论坛观点;非交易论坛,本站不对会员间交易承担任何责任。

代购请联系本站客服


RAKsmart美国服务器

QQ|手机版|小黑屋|Archiver|海外主机侦探  

GMT+8, 2017-11-18 11:00 AM , Processed in 0.137751 second(s), 30 queries .

Copyright©2008-2017 | 关于我们

快速回复 返回顶部 返回列表